Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.4

Bug #7899 Auth::sessionValidThru() returns wrong value
Submitted: 2006-06-14 13:14 UTC
From: dm2029 at mail dot ru Assigned: aashley
Status: Closed Package: Auth
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 31 - 21 = ?

 
 [2006-06-14 13:14 UTC] dm2029 at mail dot ru (Dmitry Pljonkin)
Description: ------------ Package PEAR::Auth v. 1.3.0 Auth.php,v 1.101 2006/03/02 06:53:08 Documentation (http://pear.php.net/manual/en/package.authentication.auth.auth.sessionvalidthru.php) says that Auth::sessionValidThru() returns 0 if no maximum idle time is set. But really it returns $this->session['idle'] if $this->idle is set to 0. Test script: --------------- <?php require_once('Auth/Auth.php'); $login_params = array( "dsn" => "mysql://user:pass@localhost/database", "table" => "auth_table", "usernamecol" => "Login", "passwordcol" => "Password" ); $Auth = new Auth('DB', $login_params); $Auth->start(); if ($Auth->getAuth()) { echo $Auth->sessionValidThru(); } ?> Expected result: ---------------- 0 Actual result: -------------- Current $Auth->session['idle'] value (i.e. current Unix timestamp)

Comments

 [2006-08-10 01:42 UTC] aashley at php dot net (Adam Ashley)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.