Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.6.8

Bug #3919 Typo in constant name PAYMENT_PROCESS_ERROR_INVAILD
Submitted: 2005-03-22 16:04 UTC
From: jausions Assigned: ieure
Status: Closed Package: Payment_Process
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 6 + 33 = ?

 
 [2005-03-22 16:04 UTC] jausions
Description: ------------ In Payment/Process.php typo in declaration but not in use. I'm not sure if that would lead to a BC break since the not mispelled constant name is used within the code of the class. Reproduce code: --------------- Expected result: ---------------- define('PAYMENT_PROCESS_ERROR_INVALID', -2); Actual result: -------------- define('PAYMENT_PROCESS_ERROR_INVAILD', -2);

Comments

 [2005-03-22 19:03 UTC] ieure
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.