Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.11

Bug #19770 html image cid generation on windows
Submitted: 2013-01-03 19:16 UTC
From: remy Assigned: alec
Status: Closed Package: Mail_Mime (version 1.8.7)
PHP Version: 5.3.1 OS: Windows
Roadmaps: 1.8.8    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 39 - 38 = ?

 
 [2013-01-03 19:16 UTC] remy (Rémy Böhler)
Description: ------------ In certain circumstances the uniqid can produce the same id multiple times at the same time on windows machines. (yes, WTF) When multiple images are added to the mail they could have the same id, and the images are replacing each other. The solution for the problem is easy. Setting the $more_entropy argument of the uniqid to true would suffice. Other random functions like mt_rand would work as well. Would it be possible to change the cid generation like that?

Comments

 [2013-01-03 19:22 UTC] remy (Rémy Böhler)
-Type: Bug +Type: Feature/Change Request
 [2013-06-24 13:40 UTC] alec (Aleksander Machniak)
-Status: Open +Status: Closed -Assigned To: +Assigned To: alec
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2013-06-24 16:13 UTC] alec (Aleksander Machniak)
-Roadmap Versions: +Roadmap Versions: 1.8.8
 [2013-06-24 16:13 UTC] alec (Aleksander Machniak)
-Type: Feature/Change Request +Type: Bug