Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.0

Bug #18780 PHP Deprecated: Assigning the return value of new by reference is deprecated
Submitted: 2011-09-02 21:49 UTC
From: hm2k Assigned:
Status: Open Package: PHP_CompatInfo (version 1.9.0)
PHP Version: 5.3.6 OS:
Roadmaps: 1.9.1    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 35 - 26 = ?

 
 [2011-09-02 21:49 UTC] hm2k (James Wade)
Description: ------------ The PHP_DocBlockGenerator package uses CompatInfo which uses Deprecated techniques and uses packages that use Deprecated techniques. Test script: --------------- docblockgen script.php Expected result: ---------------- No errors. Actual result: -------------- PHP Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/pear/Event/Dispatcher.php on line 249 PHP Stack trace: PHP 1. {main}() /usr/bin/docblockgen:0 PHP 2. require_once() /usr/bin/docblockgen:45 PHP 3. require_once() /usr/share/pear/PHP/DocBlockGenerator/Cli.php:39 PHP 4. require_once() /usr/share/pear/PHP/DocBlockGenerator.php:55 PHP 5. require_once() /usr/share/pear/PHP/DocBlockGenerator/Tokens.php:40 PHP 6. require_once() /usr/share/pear/PHP/CompatInfo.php:45 PHP Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/pear/File/Find.php on line 134 PHP Stack trace: PHP 1. {main}() /usr/bin/docblockgen:0 PHP 2. require_once() /usr/bin/docblockgen:45 PHP 3. require_once() /usr/share/pear/PHP/DocBlockGenerator/Cli.php:39 PHP 4. require_once() /usr/share/pear/PHP/DocBlockGenerator.php:55 PHP 5. require_once() /usr/share/pear/PHP/DocBlockGenerator/Tokens.php:40 PHP 6. require_once() /usr/share/pear/PHP/CompatInfo.php:45 PHP Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/pear/PHP/CompatInfo/Renderer.php on line 241 PHP Stack trace: PHP 1. {main}() /usr/bin/docblockgen:0 PHP 2. require_once() /usr/bin/docblockgen:45 PHP 3. require_once() /usr/share/pear/PHP/DocBlockGenerator/Cli.php:39 PHP 4. require_once() /usr/share/pear/PHP/DocBlockGenerator.php:55 PHP 5. require_once() /usr/share/pear/PHP/DocBlockGenerator/Tokens.php:40 PHP 6. require_once() /usr/share/pear/PHP/CompatInfo.php:45

Comments

 [2011-09-07 09:21 UTC] mekras (Mikhail Krasilnikov)
-Roadmap Versions: +Roadmap Versions: 1.9.1