Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.4

Bug #17462 SVN entries file regression?
Submitted: 2010-06-03 05:36 UTC
From: doconnor Assigned: dufuz
Status: Closed Package: PEAR_PackageFileManager_Plugins (version 1.0.1)
PHP Version: 5.2.12 OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 17 - 9 = ?

 
 [2010-06-03 05:36 UTC] doconnor (Daniel O'Connor)
Description: ------------ PFM_cli doesn't seem to like my svn checkouts anymore. Test script: --------------- C:\work\pear\packages\Net_IDNA\trunk>pfm C:\work\pear\packages\Net_IDNA\trunk>php c:\php\pfm PEAR Package File Manager Command Line Tool Please enter the location of your package [.]*: Enter the base install directory 1) / Please choose an option: 1 PEAR_PackageFileManager_Plugins Error: Directory "C:/work/pear/packages/Net_IDNA/trunk" is not a SVN directory (it must have the .svn/entries file) C:\work\pear\packages\Net_IDNA\trunk> Expected result: ---------------- Package file generates Actual result: -------------- C:\work\pear\packages\Net_IDNA\trunk>pfm C:\work\pear\packages\Net_IDNA\trunk>php c:\php\pfm PEAR Package File Manager Command Line Tool Please enter the location of your package [.]*: Enter the base install directory 1) / Please choose an option: 1 PEAR_PackageFileManager_Plugins Error: Directory "C:/work/pear/packages/Net_IDNA/trunk" is not a SVN directory (it must have the .svn/entries file) C:\work\pear\packages\Net_IDNA\trunk>

Comments

 [2010-06-03 06:05 UTC] doconnor (Daniel O'Connor)
Well; commenting out $this->_setupIgnore(array('*/.svn/entries'), 0); got me building packages. function dirList($directory) { static $in_recursion = false; if ($in_recursion) { return parent::dirList($directory); } // include only .svn/entries files // since subversion keeps its data in a hidden // directory we must force PackageFileManager to // consider hidden directories. $this->_options['addhiddenfiles'] = true; // $this->_setupIgnore(array('*/.svn/entries'), 0); $this->_setupIgnore(array(), 1); $in_recursion = true; $entries = parent::dirList($directory); $in_recursion = false; if (!$entries || !is_array($entries)) { $code = PEAR_PACKAGEFILEMANAGER_PLUGINS_NOSVNENTRIES; return parent::raiseError($code, $directory); } return $this->_readSVNEntries($entries); }
 [2010-06-06 17:42 UTC] timj (Tim Jackson)
What version of SVN is this? Does your working copy actually have a .svn/entries file? Or is it perhaps named differently on Windows?
 [2010-06-06 18:22 UTC] doconnor (Daniel O'Connor)
I'll check back on the svn version (probably tortoisesvn 1.6.7/8); yes there is a file.
 [2011-03-24 05:04 UTC] doconnor (Daniel O'Connor)
C:\work\pear\packages\Net_IDNA\trunk>svn help usage: svn <subcommand> [options] [args] Subversion command-line client, version 1.6.0-SlikSvn-tag-1.6.0@36687-WIN32. and Tortoisesvn 1.6.12 - so the folders should be 1.6.*
 [2011-03-28 07:49 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Open +Status: Closed -Assigned To: +Assigned To: dufuz
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.