Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.4

Bug #16111 CVS plugin does not identify CVS directories
Submitted: 2009-04-17 03:53 UTC
From: farell Assigned: cweiske
Status: Closed Package: PEAR_PackageFileManager_Plugins (version 1.0.0)
PHP Version: 5.2.9 OS: Windows XP SP3
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 43 - 20 = ?

 
 [2009-04-17 03:53 UTC] farell (Laurent Laville)
Description: ------------ With new stable version 1.0.0 of PEAR_PackageFileManager2, I wanted to try it ASAP, and I was disapointed today at my Office when I see the result. First I thought it was a wrong install , and I did it again here on my house. I've upgraded from PEAR 1.7.2 to PEAR 1.8.1 I've uninstalled old PFM 1.6.3 I've installed PFM plugins 1.0.0, then PFM2 1.0.0 I've try to use my script (package.php) to generate PHP_CompatInfo in PEAR repository without success. I got error below. So I try to change 'filelistgenerator' option from 'cvs' to 'file', and all run fine. My CVS local copy is not broken, and the CVS/Entries still exists. Test script: --------------- See http://cvs.php.net/viewvc.cgi/pear/PHP_CompatInfo/package.php Expected result: ---------------- a new version of package xml 2.0 with good results Actual result: -------------- PEAR_PackageFileManager_Plugins Error: Directory "C:/php/pear/PHP_CompatInfo" is not a CVS directory (it must have the CVS/Entries file)

Comments

 [2009-04-26 02:01 UTC] dufuz (Helgi Þormar Þorbjörnsson)
I just tried to checkout the code and do php package.php make of the bat and it worked - Except I had to fix $packagefile since you used a full windows path (you might want to point it to package2.xml so other people can use CVS) I also tried to add a new file called helgi.php in the base dir of PHP_CompatInfo, regenerate with filegenerator set to cvs, then it didn't add helgi.php but when I put file then it got added, so I am not able to reproduce this problem. Please make a new checkout of PHP_CompatInfo and see if this still happens. Keep in mind it might be a problem only on Windows, if you do the fresh checkout then we can exclude couple of problems.
 [2009-05-23 23:34 UTC] doconnor (Daniel O'Connor)
*prod* Laurent, any luck? (... can I close it?)
 [2009-05-23 23:35 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Feedback
 [2009-05-24 20:02 UTC] farell (Laurent Laville)
-Status: Feedback +Status: Open
Daniel, It's up to Helgi to choose what to do. I've already gave a solution in the PEAR dev mailing list 13 days ago. Have a look on my answer: [1] - http://news.php.net/php.pear.dev/51817 And Helgi : [2] - http://news.php.net/php.pear.dev/51818
 [2009-07-02 12:01 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Verified -Assigned To: +Assigned To: dufuz
Any chance of applying the fix of Laurent's?
 [2009-09-20 19:48 UTC] quipo (Lorenzo Alberton)
I confirm that the proposed patch [1] works. The same bug affects the SVN plugin, BTW, and bug #16287 is probably a duplicate of this one. [1] http://news.php.net/php.pear.dev/51817
 [2010-02-02 04:02 UTC] cweiske (Christian Weiske)
The change that Laurent would like to have removed would undo a fix for symlinked files on unix (bug #15244).
 [2010-02-02 04:11 UTC] cweiske (Christian Weiske)
The problem seems only to appear on Windows. Since Windows symlinks are not really widely used, it's safe for now that we add a windows specific check.
 [2010-02-02 04:47 UTC] cweiske (Christian Weiske)
-Assigned To: dufuz +Assigned To: cweiske
Please test the changes in svn which should fix the issue on windows and report back here.
 [2010-02-02 04:47 UTC] cweiske (Christian Weiske)
-Status: Verified +Status: Feedback
 [2010-02-03 00:00 UTC] farell (Laurent Laville)
Christian, The latest patch available on SVN is perfect. No problem detected on Windows platform.
 [2010-02-04 03:33 UTC] cweiske (Christian Weiske)
-Status: Feedback +Status: Closed
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/ Fixed in version 1.0.1 of PEAR_PackageFileManager_Plugins.