Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.4

Bug #1484 Extra line at end of file
Submitted: 2004-05-24 18:28 UTC
From: David dot Crim at motorola dot com Assigned:
Status: Duplicate Package: Image_Color
PHP Version: 4.3.4 OS: Fedora Core 1
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 41 + 43 = ?

 
 [2004-05-24 18:28 UTC] David dot Crim at motorola dot com
Description: ------------ I noticed that between version 0.4 and 1.0 an extra line was added to the end of the Image/Color.php file. This extra line broke the Image_Graph module for me. It caused an extra space to be output when including Image/Color.php. This caused the output to appear to no longer be an PNG file since it now starts with a " ". It also cause the attempt to change the "Content-Type" header to fail, since data had already been output. Reproduce code: --------------- Try the simple1.php script from the Image_Graph module. Expected result: ---------------- A valid PNG file. Actual result: -------------- A PNG file with an extra blank space at the begining.

Comments

 [2004-05-25 04:29 UTC] sebastian
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.