Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #13870 Notice uninstalling or using bundles
Submitted: 2008-05-10 20:36 UTC
From: yunosh Assigned: cellog
Status: Closed Package: PEAR (version 1.7.1)
PHP Version: 4.4.8 OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 + 27 = ?

 
 [2008-05-10 20:36 UTC] yunosh (Jan Schneider)
Description: ------------ pear raises a PHP notice when running the command below but works fine beside that. Test script: --------------- pear uninstall date_holidays#all Actual result: -------------- Notice: Only variables should be assigned by reference in /usr/share/php/PEAR/Command/Install.php on line 903 Call Stack: 0.0033 189824 1. {main}() /usr/share/php/pearcmd.php:0 0.2069 2632952 2. pear_command_install->run() /usr/share/php/pearcmd.php:312 0.2069 2632952 3. pear_command_install->douninstall() /usr/share/php/PEAR/Command/Common.php:285

Comments

 [2008-05-13 05:31 UTC] cellog (Greg Beaver)
I can't reproduce this - what kind of weird setup do you have? :)
 [2008-05-13 07:26 UTC] yunosh (Jan Schneider)
Heh. :) The backtrace is obviously coming from xdebug. In the reported line, $installed is assigned the result of PEAR_Registry::getInstalledGroup() by reference. But this method might return "false". The fix would be at the end of getInstalledGroup(): if (!count($ret)) { $ret = false; }
 [2008-05-13 18:32 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.