Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.4

Bug #13757 AUTH_LOG_ERR used but not defined
Submitted: 2008-04-23 19:50 UTC
From: caphrim007 Assigned: aashley
Status: Closed Package: Auth (version 1.6.1)
PHP Version: 5.2.5 OS: RHEL 4
Roadmaps: 1.6.2    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 47 - 6 = ?

 
 [2008-04-23 19:50 UTC] caphrim007 (Tim Rupp)
Description: ------------ In the Multiple container, the constant AUTH_LOG_ERR is used but doesn't appear to be defined anywhere in the Auth package. I think it should be defined in Auth.php right around line 53 where AUTH_LOG_INFO and AUTH_LOG_DEBUG are defined. By not being defined, it causes notices to be generated. Also, when the log() method is called, the AUTH_LOG_ERR is presumably empty, and won't log at the correct level. Expected result: ---------------- AUTH_LOG_ERR should be defined.

Comments

 [2008-04-27 11:19 UTC] doconnor (Daniel O'Connor)
In CVS, there's only one occurance of it - in Auth\Container\Multiple.php $this->log('Container '.$key.': '.$result->getMessage(), AUTH_LOG_ERR); Should that infact be an AUTH_LOG_INFO or AUTH_LOG_DEBUG ?
 [2008-04-28 02:33 UTC] caphrim007 (Tim Rupp)
I guess I leave that up to the developers. Looking at other files though, DEBUG is used pretty frequently.
 [2009-10-15 10:51 UTC] aashley (Adam Ashley)
-Status: Assigned +Status: Closed -Roadmap Versions: +Roadmap Versions: 1.6.2
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.