Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.16.14

Bug #13650 Examples (demodata script) problem
Submitted: 2008-04-11 09:35 UTC
From: florent Assigned: dufuz
Status: Closed Package: LiveUser (version CVS)
PHP Version: 5.2.5 OS: OSX and Linux
Roadmaps: (Not assigned)    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 44 + 43 = ?

 
 [2008-04-11 09:35 UTC] florent (Florent Bourgeois)
Description: ------------ Impossible to launch the examples 4 and 5. I tried with the last release (0.16.13) and the CVS. The problem is that the demodata.php script always quit with the same MDB2 error. My components are the following : - MDB2 2.4.1 - MDB2_Driver_mysql 1.4.1 - MDB2_Schema 0.8.2 Test script: --------------- /usr/bin/php ./demodata.php -d mysql://login:pass@localhost/liveuser_ex_5 --create=1 -f example5/demodata.xml Expected result: ---------------- Should create and populate the example database Actual result: -------------- I could not populate the database, see error below MDB2 Error: unknown error _doQuery: [Error message: Could not execute statement] [Last executed query: RELEASE SAVEPOINT MDB2_SAVEPOINT_2] [Native code: 1305] [Native message: SAVEPOINT MDB2_SAVEPOINT_2 does not exist]

Comments

 [2008-04-18 19:58 UTC] stephanas (Stephanas Francis)
We faced the same problem, but it solves when you go back to MDB2_Schema version 0.8.1 from 0.8.2: pear install -f MDB2_Schema-0.8.1 The LiveUser example 4 works with this. The other component versions in my set-up are as below: MDB2 2.5.0b1 beta MDB2_Driver_mysql 1.5.0b1 beta MDB2_Driver_mysqli 1.4.1 stable MDB2_Schema 0.8.1 beta Regards, Stephanas
 [2009-03-13 00:47 UTC] ifeghali (Igor Feghali)
I get the following error: I could not populate the database, see error below MDB2_Schema Error: schema validation error Parser error: length has to be an integer greater 0 - No error - Byte: 24710; Line: 1651; Col: 9191 with MDB2_Schema versions 0.8.1, 0.8.2 and 0.8.5 and LiveUser 0.16.13b.
 [2009-03-13 00:51 UTC] ifeghali (Igor Feghali)
Confirmed with LiveUser CVS.
 [2009-03-13 00:59 UTC] ifeghali (Igor Feghali)
The following patch has been added/updated: Patch Name: fix URL: patch fix
 [2009-03-13 01:17 UTC] ifeghali (Igor Feghali)
Just to note this seems to be a side effect of Bug #13180 which is already marked as fixed. We can: 1) fix LiveUser example as in my patch or 2) Digg MDB2 code to see whether the patch for #13180 is shipped with 2.5.0b1 or is in CVS only.
 [2009-03-13 01:31 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Open +Status: Closed -Assigned To: +Assigned To: dufuz
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.