Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.13.3

Bug #12654 The Window handler is not working properly.
Submitted: 2007-12-11 11:20 UTC
From: ratsbomb Assigned: jon
Status: Closed Package: Log (version 1.9.11)
PHP Version: 5.1.6 OS: Linux(CentOS5)
Roadmaps: 1.9.12    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 43 - 17 = ?

 
 [2007-12-11 11:20 UTC] ratsbomb (Andrew, Ahn)
Description: ------------ Server OS : Linux(CentOS 5) PHP : 5.1.6 Client : Windows XP Browser : Firefox 2.0.0.11, IE 7.0.5730.13 in win.php, 200~202 200 /* Buffer the output until this page's headers have been sent. */ 201 if (!headers_sent()) { 202 return; 203 } When I commented that lines, then I see log message. I wonder, Is really header sented? Test script: --------------- <?php require_once "Log.php"; $conf = array('title' => 'Sample Log Output'); $logger = &Log::singleton('win', 'LogWindow', 'ident', $conf); $logger->log("Log entry ..."); ?> Expected result: ---------------- Info : Log entry... Actual result: -------------- In FireFox, opened window just see log table's column name Time/Ident/Priority/Messsage In IE 7.0, opened window can't display anything.(just blank page) in both of them, no log message appeared.

Comments

 [2007-12-11 17:04 UTC] jon (Jon Parise)
I'm having trouble reproducing this. Your test script is working fine for me. Can you capture what's actually being sent to the browser (i.e. "view source") and include that in the bug report?
 [2007-12-12 01:11 UTC] ratsbomb (Andrew, Ahn)
in firefox, I can't see sources. because log window's status bar is loading. http://www.xinuwiki.com/temp/logwin_ff.gif in ie7 http://www.xinuwiki.com/temp/logwin_ie7.gif I can only view a source in ie7.(below) <!-- Source Start --> <html> <head> <title>Sample Log Output</title> <style type="text/css"> body { font-family: monospace; font-size: 8pt; } td,th { font-size: 8pt; } td,th { border-bottom: #999999 solid 1px; } td,th { border-right: #999999 solid 1px; } tr { text-align: left; vertical-align: top; } td.l0 { color: red; } td.l1 { color: orange; } td.l2 { color: yellow; } td.l3 { color: green; } td.l4 { color: blue; } td.l5 { color: indigo; } td.l6 { color: violet; } td.l7 { color: black; } </style> </head> <body> <table border="0" cellpadding="2" cellspacing="0"> <tr><th>Time</th> <th>Ident</th> <th>Priority</th><th width="100%">Message</th></tr> <!-- Source End --> Where is the Window Handler Header sented in source code? because in my case, No header sented, so I can't see log message.(so, I commented that lines(whether header sented.), then I can see log message properly.
 [2007-12-12 04:50 UTC] ratsbomb (Andrew, Ahn)
I found the reason. output_buffering setting in php.ini if output_buffering enabled, don't work properly register_shutdown_function() what we means. so, i tried to using ini_set() function to set output_buffering disable. but it didn't work. it's may be php bugs or other things. thus, i edited output_buffering disable in php.ini, restart apache. everything is going well. It's not Log_win Class's problem.
 [2007-12-12 05:20 UTC] jon (Jon Parise)
Great. I'll add a warning to the documentation. Thanks!