Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.2

Bug #12264 Warnings & notices
Submitted: 2007-10-17 13:45 UTC
From: troehr Assigned: doconnor
Status: Closed Package: Science_Chemistry (version CVS)
PHP Version: 4.4.7 OS:
Roadmaps: (Not assigned)    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 8 + 33 = ?

 
 [2007-10-17 13:45 UTC] troehr (Torsten Roehr)
Description: ------------ Hi, there are a few warnings & notices popping up when using the package with newer PHP versions. Please apply the patches below to fix the warnings & notices described here: http://phpfi.com/269512 Thanks and best regards, Torsten Roehr

Comments

 [2008-01-17 14:33 UTC] kguest (Ken Guest)
Thanks Torsten, I'm a member of the PEAR Quality Assurance team and have emailed the maintainer of this package several times about fixing this bug. I have not received any replies regarding this and following QA Guidelines a set period of time must elapse before I fix this bug on the maintainer's behalf. That period will expire on 2007-01-22. Ken
 [2008-01-21 01:32 UTC] jmcastagnetto (Jesus M. Castagnetto)
This package was designed for PHP 3 and PHP 4, not for PHP 5, mainly because back when this code was written, the newest version to be was PHP 4, therefore fixing it as suggested by the bug reporter will destroy the usefulness and expected behavior for the intended PHP versions. The couple of notices will be fixed in CVS, although they pose no problems in PHP 3 or 4. A newer package designed to take advantage of PHP 5's characteristics is in the works and will be release under a new name when it is done. Thanks for the report, but you got to understand that there is no such thing as 100% forward compatibility, and the issues reported do not cause running time errors (fatal). Cheers.
 [2010-10-04 17:32 UTC] doconnor (Daniel O'Connor)
-Status: Wont fix +Status: Open
 [2011-08-08 08:03 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.