Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.3.3

Bug #11447 Underline does NOT work
Submitted: 2007-06-26 18:35 UTC
From: avapex Assigned: yunosh
Status: Closed Package: File_PDF (version 0.2.0)
PHP Version: 5.0.4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 23 + 19 = ?

 
 [2007-06-26 18:35 UTC] avapex (Jonathan Runquist)
Description: ------------ When using the following command: $pdf->setFont('Helvetica', 'U', 48); The text is not underlined, rather the underline appears at the bottom of the page. Test script: --------------- <? header('Content-type: application/pdf'); require_once dirname(__FILE__) . '/../PDF.php'; $pdf = &File_PDF::factory(); $pdf->setCompression(false); $pdf->open(); $pdf->addPage(); $pdf->setFont('Helvetica', 'U', 12); $pdf->write(15, "TEST OUTPUT"); echo $pdf->getOutput(); ?> Expected result: ---------------- Underlined Text

Comments

 [2007-06-29 09:30 UTC] yunosh (Jan Schneider)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.